This article was first published on: Litecoin Project - Medium --

Follow the Google+ page or Twitter for the latest dev news.

Summary

This is a critical update for the openssl compatibility issue as documented for Bitcoin by gmaxwell. If you build Litecoin from source you MUST upgrade to Litecoin v0.8.7.5 because your operating system’s openssl has become incompatible in a security update for CVE-2014–8275. This is especially important for Linux users and mining pools who built from source.

Technical Changelog

  • v0.8.7.5
  • Critical: Maintain consensus with openssl-1.0.1k+ or CVE-2014–8275.
  • If you are running the v0.8.7.4 binaries from litecoin.org you do not need to upgrade as that contained an older version of openssl before the consensus breaking change in openssl-1.0.1k. v0.8.7.5 was released primarily to remove all confusion about what version is safe to operate.
  • v0.8.7.4
  • Enforce v2 blocks at height 710000 on mainnet, 400000 on testnet
  • All miners must upgrade prior to this point or they run the risk of losing future block rewards.
  • Add `-maxorphantx=` option fo...

This content is synced from the rightful owners. Copyright on text and images belong to the original source. -- This article was first published on: Litecoin Project - Medium